close

Privacy guaranteed - Your email is not shared with anyone.

Problems with Revo STX

Discussion in 'Tackle Talk' started by bgrapala, Mar 4, 2009.

  1. bgrapala

    bgrapala Micropterus dolomieu

    727
    59
    483
    Has anyone had any issues with these reels? I bought one on friday and practiced a little with it with no problems. I went out of town for the weekend and came back and whenever i turned the mag brake on it made this horrible metal on metal grinding sound. I called Pure Fishing and they told me to take it back to BPS. I took it back and exchanged it, the new reel...same thing no problems in the store. Brought it home and before I spooled it up with line I decided to mess with it to see if I could get it to make the same noise. Sure enough the exact same noise happened whenever i turned the mag brake on even at the lightest setting. I called Pure Fishing again and this time they told me just to send the reel to them. So after 2 trips to BPS and a 14.50 shipping charge I should get the reel back no problems. I was just wondering if anyone else was having issues with the mag brakes on Revo reels? I have an SX that is smooth as silk and have had no problems with it at all.
     
  2. I have 4 of them, and never had the slightest issue with any of them.
     

  3. Did you put braid on it and if you did did you put a mono backing on
     
  4. That has nothing to do with his metal on metal grinding sound from turning on the mag brakes.
     
  5. Tokugawa

    Tokugawa Tackle addict

    I'm assuming that as some point in time you turned the mag brake and it did not make noise. Then it did make noise when turned a short time later. Is this correct?
     
  6. bgrapala

    bgrapala Micropterus dolomieu

    727
    59
    483
    tokugawa, yes that is correct. I purchased the reel on Friday and threw it in the back yard for about 10 minutes and put it up over the weekend. I picked it up and went to throw it again and it was making that noise. As soon as I brought the other one back it started making that noise again as soon as I put it on a pole. Now I didn't check the mag brakes in the store...I really should have. As far as putting line on it...the only time I use braid is on my jig pole. I spooled it with 10 lb Trilene XL. And yes I know to use mono backing with braid. I'm positive it was a problem with the mag brakes...it sounded like there was a bushing missing or something...I just want my reel back soon!!
     
  7. Tokugawa

    Tokugawa Tackle addict

    The only Abu I have with a mag brake has a click spring it. If that goes, it can make a grinding noise. Maybe that is it?

    Hope you get it back soon!
     
  8. bgrapala

    bgrapala Micropterus dolomieu

    727
    59
    483
    Probably...I'll find out soon hopefully