close

Privacy guaranteed - Your email is not shared with anyone.

Minn Kota PowerDrive

Discussion in 'Boats and Motors' started by I Fish, Oct 15, 2008.

  1. I Fish

    I Fish I am what I eat.

    1,518
    123
    898
    Can anyone help me with a Minn Kota power drive? I bought it 2 1/2 years ago, so it is 6 months out of warranty, although it really hasn't seen that much use. Last weekend it sort of died on me. It still turns to steer, but the prop will only turn a quarter turn then stop, quarter turn stop, quarter turn stop. It will continue doing that, no matter what speed it is set on, and doesn't matter if it's on continuous, or momentary. I removed the prop to look for a wrap up, but found nothing. Also, with the prop off, the motor shaft still rotates as stated above. Thanks in advance................
     
  2. Doctor

    Doctor CJ Cat Attack Pack

    Try checking your battery conections first then go to the plug connections next............Doc
     

  3. tubuzz2

    tubuzz2 1700 Lund Red and tan

    There are two screws in the after taking the prop off. Unscrew to open up the bottom unit. Watch out for the water! If water runs out the contact are dirty on the brush for the motor.
     
  4. Yep...sounds like a brush block problem. Get a pencil eraser and clean them off on the motor and on the wire side (2 copper wires with metal blocks attached to them. There should be a cardboard sleeve behind the opening for the motor that will be used to hold the blocks in position when you re-install the motor portion. It'll push out of way when you push the motor into position. If it's not there, use a small screwdriver or 2 and make sure the springs are in place behind the blocks when you re-install.
     
  5. I Fish

    I Fish I am what I eat.

    1,518
    123
    898
    I'll try that, but probably won't get back to my boat until 1st of November. I'm leaving for a cruise Saturday morning. Do you know if they have rod holders on cruise ships. Thought I might take my rods and planer boards. lol Anyway, do you think the motor has leaked water, and is there a seal I need to be concerned with?
     
  6. I Fish

    I Fish I am what I eat.

    1,518
    123
    898
    OK, I cleaned the brushes and everytihng. There was no water leaking in. Anyway, after I put it back together, I turned it on, and there was smoke coming from under the cover at the top of the mount. I removed it and found a circuit board, and it was hot. Is the a voltage regulator, and does anyone know where to get a replacement? Thanks.............
     
  7. Same exact problem i was having with my motorguide. I hate to break the bad news to you but when mine done that it was one of two problems. 1. the circuit board. 2. the switch of course my motorguide was out of warranty and the circuit board was out of date but it works now on high bypass after bypassing the circuit board and wiring the wires together. If you need any help send me a pm or email me and i will be happy to assist you on this.
     
  8. I Fish 614 895 2628 Ty Clarkson in Westerville ohio he is the local out of his house Minn Kota factory guy. Tight Lines Fishguy