Ohio Game Fishing banner

1 - 4 of 4 Posts

·
Where's Waldo?
Joined
·
1,130 Posts
Discussion Starter #1
My 4 year old 597 has suddenly developed a problem with the buttons not working. So far, MENU, EXIT, and VIEW are not working. + and - seem to change the views. GOTO will open the pulldown box but then the arrow keys don't work. I've power cycled it several times. I would reset defaults but I can't because the MENU button doesn't do anything. Does anyone know if there's a secret trick or combination of buttons that will reset this box? I know I could send it to Humminbird but they'll want $300.00 or so to fix it and a new equivalent would be less than $500.00.

Any suggestions would be appreciated.

Thanks,

MC
 

·
Registered
Joined
·
4,346 Posts
Just contact Humminbird tech support. It's free, and they should be able to help you with your problem. I prefer to call and talk to someone, but you can also email them from their site and get an answer.
 

·
Where's Waldo?
Joined
·
1,130 Posts
Discussion Starter #3
I'll try to call them tomorrow but the last time I did that they just said to send it in with my $265.00, or whatever it was. That's been a couple of years ago so maybe it's better now.

Thanks,

MC
 

·
Registered
Joined
·
472 Posts
I just read through my owner manual to see if they had any trouble shooting, but no luck. Last time I called them for a few questions, they were very helpful, but I had not repair needed either. let us know how the customer support is.

Good luck!
 
1 - 4 of 4 Posts
Top